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Overview

Gopher is an Internet access protocol that allows server machines to publish material or resources, and 
client machines to receive these resources. With Gopher, you can browse through the Internet by 
selecting resources from menus. Much like browsing through a remote library's card catalogue and 
automatically fetching the material you want, Gopher helps you access any of the data it presents.      

The resource material consists of data in a variety of formats such as text, images, sounds, and services 
such as Telnet connections, index servers, and phone book servers.      It does not matter where the 
resources are located, as long as they are part of the Gopher system which is often called GopherSpace.

While documents reside on many servers, Gopher presents you with a hierarchy of items much like a file 
system.    Each item is labeled by an icon which identifies it as a: directory, text file (.txt), graphics file 
(.gif), phonebook, or searchable index.



Setting Up Gopher

The NetManage Gopher client requires no special setup or configuration.    however, the network on which
Gopher runs must be properly configured, and you need to make sure that the File Manager associations 
exist between certain file types and their viewers.    To see if the proper network connection exists, select 
the 
Diagnose Connection option from the Help menu.

Gopher uses the File Manger file association system to determine the appropriate viewer program for 
viewing different types of files.    For example, files with the .txt extension should be associated with a 
viewer such as Notepad or Write.    To view GIF images, you must have a GIF image viewer and 
associate it to the .gif extension.



Starting Gopher

When you first start Gopher, a directory window appears.    This window is split; the left half displays the 
directory tree and the current directorys contents, while the right half displays only the current directorys 
contents.

The Gopher interface resembles a file system much like File manager and tracks two types of items:    
directories and resources.    All resources are accessed through directories.    Directories and individual 
resources are labeled with their own distinct icon.

Under the Symbol Legend option    under the Help menu you can view a list of all the resources. 

A configuration file is maintained that stores GopherSpace hierarchy information and user preferences.



Retrieving Information

Gopher stores everything it retrieves in a local directory because published gopher resources do not 
change often and at times the resources may be difficult to retrieve (servers may not always be up and 
communication links may be slow).

Gopher retrieves two types of information:

hierarchical information which appears in the GopherSpace display and is stored in the 
configuration file.

You can open a Gopher item by choosing the Retrieve Item option from the Item menu.    This option 
retrieves the selected item directly from the Gopher server and then opens it.    When you close the 
item it is automatically placed in your gopher cache directory.

file information which is stored in the gopher cache directory (which you set up in Preferences).    
These files are often named with the letter G, a number, and an extension indicating file type.

After an item is closed and placed in the gopher cache directory you can open it again using the Open
option from the Item menu.    However, it may contain the most current update since you did not 
retrieve and open the item directly from the Gopher server.

The configuration file defaults to the name GOPHER.CFG and the gopher cache directory is called 
gopher.    By default, both are stored in the same directory in which gopher was installed.



Navigating Around GopherSpace

The GopherSpace hierarchy is divided into two sections:    bookmarks and gopher servers.    Bookmarks 
are items of specific interest which have been copied from elsewhere in the hierarchy for convenient 
access using the Set Bookmark option from the Item menu.

Servers are references to the gopher server machines which act as a starting point for exploring the 
gopher hierarchy. 

In the Gopher window left hand view, you can select items by clicking on them or using the arrow keys.    
For example, to view the contents of a directory, double-click on the desired directory.    Additional 
directories and/or files, index searches, or phonebooks may also appear.    As you continue to move 
through the directory in search of items of interest, the file system will expand.    To collapse any part of 
the file structure, double-click on the directory you want to close.

You can retrieve items in the right hand view but you cannot select items in the right hand view because it
just tracks the left hand view.    



Subscribing to a Gopher Server

The University of Minnesota publishes a list of Gopher servers which is included as one of the default 
bookmarks.    This list contains the servers whose owners have submitted a request to the university to be
placed on the server list.

To add a server to your hierarchy, select the Add Gopher Server option from the Items menu.    Enter the 
required information, choose OK and a directory icon will appear in the servers list bearing the new server
name.



New

New creates a new configuration file (*.cfg file).    When you choose the New option, Gopher provides you 
with a default configuration file. 

To select a new configuration file:

Select the New option from the File menu.



Open...

Open... opens an existing configuration file.    When you select Open, Gopher allows you to load an 
existing configuration file.

To open an existing configuration file:

1. Select the Open... option from the File menu.

2. Select the desired drive, directory and file.

3. Choose the OK button.



Save

Save saves configuration parameter changes to the default file.

To save configuration parameter changes:

Select the Save option from the File menu.



Save As...

Save As... allows you to select the file name, directory, and drive you want to use for saving configuration 
parameters.

To save configuration parameters in desired location:

1. Select the Save As... option from the File menu.

2. Select the desired drive and directory.

3. Enter the filename into the text box.

4. Choose the OK button.



Exit

Exit allows you to exit Gopher.

To exit Gopher:

Select the Exit option from the File menu.



Retrieve item

Retrieve Item retrieves a selected item from the network and places it in local storage.    Use this option 
when you want to retrieve an item that contains the most recent update.

To retrieve an item from the network:

1.      Select the item you want to retrieve.    It can be a menu, text file, or graphics file.

2.      Select the Retrieve Item option from the Items menu.    The selected item is retrieved from the 
network and then opened.



Close Item

Close Item closes selected item and collapses its substructure.

To close an item:

1.      Select the item you want to close.

2.      Select the Close Item option from the Settings menu.



Open Item

Open Item opens a selected item from local storage either expanding its substructure or starting a viewer
on the local file.    Use this option when you want to open an item that currently resides in your local 
directory.    Note that the item may not contain the most recent update.

To open an item:

1.      Select the item you want to open.

2.      Select the Open Item option from the Items menu.



Retrieve Info

Retrieve Info displays directory information about the selected item.

To retrieve information about an item:

1.      Select the item whose directory information you want to view.

2.      Select the Retrieve Info option from the Items menu.

A window appears (Notepad.txt) that contains directory information such as administration and 
modification data about the item.



Set Bookmark

Set Bookmark copies the current selection into the bookmark section.    Bookmark allows you to access a 
selected item directly without having to search for it by going up and down the Gopher Space tree.

To copy a current selection to the bookmark section:

1.      Select the item that you want to copy to the bookmark section.

2.      Select the Set Bookmark option from the item menu.    The selected item now appears in the 
bookmark section.



Go Back

Go Back selects a previously selected item.

To select an item you previously selected:

Select the Go Back option from the Item menu.    The previously selected item will be selected again.



Search

Search... allows you to search for and open a specific gopher item from the list of items you have stored 
on your local disk.

To search for specific gopher item:

1.      Select the Search... option from the Items menu.    The GopherSpace Keyword Index dialog box 
appears.

2.      Enter a single word in the field, or select one from the word list.    All titles that have that word appear 
in the bottom field.

3.      Select the gopher item you want to open and press the Go To button.    The main Gopher window 
appears with the selected title highlighted.



Copy to File...

Copy To File... copies retrieved data to a file.

To copy retrieved data to a file:

1. Select the item you want to copy to a file.

2. Select the Copy To File... option from the Items menu.

3. Select the desired drive, directory and file name.

4. Choose the OK button.



Move to File...

Move To File... moves retrieved data to a file.

To move retrieved data to a file:

1. Select the item you want to move to a file.

2. Select the Move To File... option from the Items menu.

3. Select the desired drive, directory and file name.

4. Choose the OK button.



Add Gopher Server...

Add Gopher Server... allows you to add Gopher Servers to the Gopher Server list.

To add a Gopher Server:

1.      Select the Add Gopher Server... option from the Items menu.    The Add Gopher Server dialog 
box appears and contains the following fields:

Name Displayed:    The name of the Gopher Server you want to add.

Host Name:The name of the host where the Gopher Server is located.

Port Number:The protocol port number on which the Gopher Server listen (usually 70.)

2.      Enter the information into the fields.

3.      Choose the OK button.



Item Properties...

Item Properties... displays properties of the selected item.

To display the properties of a selected item:

1. Select the item whose properties you want to display.

2.      Select the Item Properties... option from the Items menu.    The Gopher Item Properties dialog 
box appears containing the following information:

Entry Type:      Defines the type of item as either a directory, CSOIndex, file, error or one of several other 
types.    Refer to RFC 1436, section 3.8 for a complete list of entry types.

Name Displayed:      The name of the selected item.

Selector:      Gopher Server-dependent item identifier.

Host Name:      The name of host where the Gopher Server resides.

Port Number:      The protocol port number on which the Gopher Server listen (usually 70.)

Gopher+ Support:      Whether the Gopher Server supports the Gopher+ protocol.



Remove Item

Remove Item removes the selected item from your Gopher Server list.

To remove an item:

1. Select the item you want to remove.

2. Select the Remove Item from the Items menu.



Preferences...

Select the Preferences... option from the Settings menu and select each preference you want to activate.

Gopher File Cache

The Gopher File Cache contains the name of the directory where you GOPHER.CFG file is stored. 

Commands

The Commands preferences list the emulators and the diagnostic tool you are using.    For Chameleon 
users the default values are:

Telnet:TELNET.EXE
Telnet 3270:TN3270.EXE
Diagnostic:Ping



Colors ...

Colors... allows you to select both the foreground and background colors for your screen display.    A 
palette of 16 colors is available.

To select colors for your screen display:

1. Select the Colors... option from the Settings menu.

2. Select the background color and the foreground color.

3. Choose the OK button.



Log...

Select the Log... option from the Settings menu to help diagnose client transmission and Gopher server 
retrieval problems.    

1.      Select the Log... option from the Settings menu.

2.      Choose the Start button to start logging, or the Stop button to stop logging.

3.      Choose the Save button to save the contents of the log window to the GOPHER.LOG file.

4.      Choose the Print button to print the contents of the log window.

5.      Choose the Copy button to copy the contents of the log window onto the clipboard.

6.      Choose the Clear button to clear the log window.

7.      Choose the Close button to close the Log... option dialog 



Toolbar ...

Toolbar allows you to display or hide the application's toolbar.    The    toolbar gives you quick mouse 
access to several of the Gopher tools.    Some of the toolbar functions include:

creating a new configuration file
opening an existing configuration file
saving configuration parameter changes to the default file
retrieving selected items from the network into local storage
opening selected items from local storage
closing selected items and collapses their substructure
retrieving information about selected item
copying current selection into the Bookmark section
selecting a previously selected item
displaying the Gopher application serial number and version information



Smart Buttons

Smart Buttons allows you to display toolbar icons, including each icon's descripton.



Status Bar

Status Bar allows you to display or hide the application's status bar.    The status bar is displayed at the 
bottom of the window where it shows messages and provides statistics about the current application.



Troubleshooting

If you experience difficulties using the Gopher application, refer to the following items:

o Make sure that the installation and setup verification steps have been successfully completed.

o If you cannot connect to a specific server during peak hours, try connecting again during off hours.    
Use the Diagnose Connection option to start Ping and verify that the server is available.

o Gopher should clean up after itself by deleting files in the cache directory when appropriate.    However, 
it is possible to "orphan" files, so you may want to purge your cache directory occasionally.



Diagnose Connection

Use the Diagnose Connection option to start Ping and verify that the server is available.



Contents

Using Help

To choose a Help topic:

Mouse Point to the underlined topic you want to view and click the mouse button.

When the pointer is over an item you can choose, the pointer changes to a hand 
icon.

Keyboard Press Tab to move the highlight to the underlined topic you want to view, and 
then press Enter.

To exit Help:

Mouse                        1      Point to the File menu and click the mouse button.

2      Click the Exit command.

Keyboard                    1      Press Alt.
2      Type the letter F.
3      Type the letter X.



Symbol Legend

The Symbol Legend menu provides a graphic and description of each Gopher icon legend.    Gopher 
icon legends include:

Gopher icon legend include in alphabetical order:
CSO Phone Book
DOS or Windows Binary File
Directory
GIF Image File
Generic Binary File
Generic Image File
Index Server Item
Macintosh BinHex Item
Section Heading
TN3270 Server
Telnet Server
Text File
Unix UUENCODE File
Unknown Item Type.



About Gopher...

Select the About Gopher... option from the Help menu for information about this program.    Choose the 
OK button to continue.






